Uganda data services temporary suspension.

Incident Report for IoTKinect

Resolved

This incident has been resolved.
Posted 4 days ago. Jan 19, 2026 - 07:38 UTC

Monitoring

Dear customers, according to our monitoring and statistic traffic from Uganda restored. We are waiting for the official confirmation and continue monitoring.
Posted 4 days ago. Jan 19, 2026 - 07:37 UTC

Monitoring

We are continuing to monitor for any further issues.
Posted 9 days ago. Jan 13, 2026 - 17:00 UTC

Monitoring

Dear Customers, Please be informed that, according to the Uganda Communications Commission, data services in Uganda have been temporarily suspended due to election-related procedures. Unfortunately, IoTKinect has no influence over this situation. We will keep you updated as soon as new information becomes available.
Posted 9 days ago. Jan 13, 2026 - 17:00 UTC
This incident affected: Data Connectivity.