Brussels B22 Data Center Power Work

Incident Report for IoTKinect

Completed

The scheduled maintenance has been completed.
Posted 12 days ago. Feb 26, 2026 - 12:00 UTC

In Progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 12 days ago. Feb 26, 2026 - 06:00 UTC

Scheduled

Maintenance will begin as scheduled in 60 minutes.
Posted 12 days ago. Feb 26, 2026 - 05:00 UTC

Scheduled

Dear customers As part of our continued commitment in providing the best in class services to our valued customers worldwide, IoTKinect will perform Power Works in our Brussels B22 data center. No impact is expected and close monitoring is organised by IoTKinect.
Posted 25 days ago. Feb 13, 2026 - 16:05 UTC
This incident affected: Data Connectivity.