Maintenance works on SFT platform (HSS).

Incident Report for IoTKinect

Completed

The scheduled maintenance has been completed.
Posted 1 day ago. Mar 9, 2026 - 08:39 UTC

In Progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 1 day ago. Mar 9, 2026 - 08:00 UTC

Scheduled

Maintenance will begin as scheduled in 60 minutes.
Posted 1 day ago. Mar 9, 2026 - 07:01 UTC

Scheduled

Dear customers, As a part of our continued commitment in providing the best in class services to our valued customers worldwide, we will execute planned maintenance works on SFT platform (HSS). Please note that no impact is expected for your traffic. We will check the availability of your services during and after the maintenance window has passed. In the exceptional situation if you detect something abnormal please do not hesitate to contact our support team at [email protected].
Posted 8 days ago. Mar 2, 2026 - 15:25 UTC
This incident affected: Signalling Connectivity.