Data Service Degradation.

Incident Report for IoTKinect

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 18:04 UTC

Monitoring

Dear Partner, Please note that the issue has been resolved. We are continuously monitoring the service closely to ensure service availability and stability. Thank you. Kind Regards, IoTKinect Support Team.
Posted Jul 21, 2026 - 17:49 UTC

Investigating

Dear Partner, We are observing partial degradation on data services. We are aware of this issue and working on resolving it. Further information will be shared. Thank you for your understanding. Kind Regards, IoTKinect Support Team.
Posted Jul 21, 2026 - 17:00 UTC
This incident affected: Data Connectivity.